Vous êtes ici : 6.0 > Guide d'installation et d'exploitation > Pré-requis logiciels

Pré-requis logiciels

Les solutions K-Portal / K-Sup sont des solutions JEE (Java Enterprise Edition) éditées par la société Kosmos et basées sur les composants open source les plus stables et matures du marché.

Bâtis sur des standards (cf. process et technologies utilisées), ces logiciels sont basés sur une architecture n-tiers distinguant frontal Web, application, et données.


Schéma des pré-requis pour un hébergement K-Portal / K-Sup

> Plus d'informations sur l'environnement logiciel

Système d'exploitation

Kosmos recommande l'utilisation des dernières distributions stables de Linux. Nous garantissons le bon fonctionnement de K-Portal / K-Sup avec les distributions suivantes :
  • GNU Linux Debian 8 Jessie 64 bits
  • Red Hat Enterprise Linux 7 64 bits
Ces distributions sont pré-équipées avec un certain nombre de composants stables qui seront par la suite mis à jour avec les patchs de sécurité. Kosmos recommande de suivre régulièrement les mises à jour de sécurité.

Versions recommandées pour les composants

Nos logiciels supportent les composants les plus récents actuellement disponibles en standard dans les dernières distributions stables de Linux.

Composant Version
SGBD MySQL Server 5.5
ou
MariaDB 10.0 à partir de la version 6.4 de K-Portal / K-Sup
Java Open JDK 7
ou
Oracle JDK 7 (à télécharger sur le site d'Oracle)
Tomcat Tomcat 7.0.50 pour versions 6.0 et 6.1 de K-Portal / K-Sup
Tomcat 7.0.x pour les versions 6.2
Tomcat 8.x à partir de la version 6.3 de K-Portal / K-Sup
Apache Apache 2.2
ou
Apache 2.4 à partir de la version 6.4 de K-Portal / K-Sup
avec mod_jk 1.2

Fin de support public pour JDK 7

Oracle a annoncé la dernière version publique d'OpenJDK 7 à compter d'avril 2015. Cela ne signifie pas pour autant la fin de vie de la version car les distributions utilisent des paquets maintenus :Pour les utilisateurs souhaitant migrer sur le JDK 8, la version a été validée sur des environnements de test. Nous n'avons pas identifié de risques particuliers et les versions 6.x de K-Sup peuvent être déployées sur OpenJDK 8. Nous préférons néanmoins continuer à appliquer notre politique de support des composants techniques, à savoir recommander les composants proposés par défaut dans les versions stables des distributions.